Problem with non-persistent EJBTimer

I am unable to implement non-persistent EJBTimer using version 6.2023.5 . It used to work on version 5.2022. I am getting excetption RAR5099 : Wrong class name or classpath for Datasource Object
java.lang.ClassNotFoundException: org.apache.derby.jdbc.EmbeddedXADataSource

Since I am using a non-persistent timer, I’m not sure why it is using a datasource at all. I see it is using __TimerPool which uses connection pool __TimerPool. I added Derby jar to my pom which contains EmbeddedXADataSource but still getting similar exception. I also tried using my own db schema and got a table not found exception.

I’ve researched a number of posts about this but have not seen a definitive answer. Some say to add the derby jar, some say to run an asadmin command to increase threads. I see that previous versions of payara had derby jars in javalib/lib. I’ve also seen comments about needing to delete files that may be left as a result of initially using __TimerPool.

I’m at a loss as it used to work in previous versions and also that I’m not using a persistent timer.

Well, I got this to work. I pointed __TimerPool to my schema and added EJB_TIMER_TBL table using script provided with payara. This was just a guess that worked. Since I’m using a non-persistent timer it doesn’t make sense that it would need a jdbc resource. Also, I would have hoped to find some documentation about this as it is something that worked out of the box in previous versions of payara and glassfish not to mention weblogic. Next I will configure persistence.xml to use an existing jdbc resource rather than __TimerPool.