Running App on Payara Server throws "Error occurred during initialization of VM"

I’m a junior developer and this is my first question here, sorry if I write something wrong.

I’m currently updating very old application that first used Java 8, JavaEE6, ANT, Microsoft SQL Server and Payara 5.184, it has 2 modules, 1 ejb and 1 front with java swing

I was able to change to Maven, java 17, JakartaEE10. I didn’t figure out how to check if it was all working, so I decided to do the sames steps to deploy on Payara Server.

I had to update the Payara server too :frowning:

But when I try to make everything work I got the following error:

OpenJDK 64-Bit Server VM warning: Archived non-system classes are disabled because the java.system.class.loader property is specified (value = "org.glassfish.appclient.client.acc.agent.ACCAgentClassLoader"). To use archived non-system classes, this property must not be set
Error occurred during initialization of VM
java.lang.Error: org.glassfish.appclient.client.acc.agent.ACCAgentClassLoader
        at java.lang.ClassLoader.initSystemClassLoader(java.base@17.0.10/
        at java.lang.System.initPhase3(java.base@17.0.10/
Caused by: java.lang.ClassNotFoundException: org.glassfish.appclient.client.acc.agent.ACCAgentClassLoader
        at jdk.internal.loader.BuiltinClassLoader.loadClass(java.base@17.0.10/
        at jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(java.base@17.0.10/
        at java.lang.ClassLoader.loadClass(java.base@17.0.10/
        at java.lang.Class.forName0(java.base@17.0.10/Native Method)
        at java.lang.Class.forName(java.base@17.0.10/
        at java.lang.ClassLoader.initSystemClassLoader(java.base@17.0.10/
        at java.lang.System.initPhase3(java.base@17.0.10/

I don’t know what to doo, I already tried to change the Payara to a docker container, same error, and the few posts on internet didn’t help me.

I did the following Steps:

1 - Create a APP.ear

2 - Used the maven-assembly-plugin to create a client.jar

3 - /…/payara6/glassfish/bin/asadmin deploy --force=true --retrieve /tmp/ /…/APP.ear (to deploy on Payara).

4 - /…/payara6/glassfish/bin/appclient -client /…/client.jar -targetserver -verbose (this to make all work)

5 - error :frowning:

Could someone help me?